guzziriders.org - moto guzzi forum Homepage
Forum Home Forum Home > Technical > Spine Frame
  New Posts New Posts RSS Feed - 1998 Sporti Not Communicating with Diagnostic PC
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

1998 Sporti Not Communicating with Diagnostic PC

 Post Reply Post Reply Page  <1234>
Author
Message
Guztave View Drop Down
Senior Member
Senior Member


Joined: 30 Nov 2014
Location: Exeter
Status: Offline
Points: 308
Post Options Post Options   Thanks (0) Thanks(0)   Quote Guztave Quote  Post ReplyReply Direct Link To This Post Posted: 14 Nov 2018 at 15:05
Hi Johnno,

Yes, fuel pump continually running ...
Back to Top
johnno View Drop Down
Senior Member
Senior Member


Joined: 19 Jul 2014
Location: loughborough uk
Status: Offline
Points: 3809
Post Options Post Options   Thanks (0) Thanks(0)   Quote johnno Quote  Post ReplyReply Direct Link To This Post Posted: 14 Nov 2018 at 19:15
Have you checked relays and wiring . I took rear body work off so you can get to the wiring that goes to relays . 
1100 sport corsa rider
Back to Top
Guztave View Drop Down
Senior Member
Senior Member


Joined: 30 Nov 2014
Location: Exeter
Status: Offline
Points: 308
Post Options Post Options   Thanks (0) Thanks(0)   Quote Guztave Quote  Post ReplyReply Direct Link To This Post Posted: 14 Nov 2018 at 19:29
Yes, relays are good but order new ones from PYRO DAN to be sure and removed all body work.

Thanks for your help.
Back to Top
Mike H View Drop Down
Senior Member
Senior Member
Avatar

Joined: 21 May 2014
Location: East Anglia
Status: Offline
Points: 6497
Post Options Post Options   Thanks (0) Thanks(0)   Quote Mike H Quote  Post ReplyReply Direct Link To This Post Posted: 14 Nov 2018 at 21:00
Is ECU actually getting any electric supply? E.g. dodgy connector(s) ...



"Chicken nuggets don't dance on a Tuesday."
Back to Top
johnno View Drop Down
Senior Member
Senior Member


Joined: 19 Jul 2014
Location: loughborough uk
Status: Offline
Points: 3809
Post Options Post Options   Thanks (0) Thanks(0)   Quote johnno Quote  Post ReplyReply Direct Link To This Post Posted: 14 Nov 2018 at 21:03
When you have fuel pump running have you wiggle the relays ? My bike nearly drove me mad with problems . 
1100 sport corsa rider
Back to Top
johnno View Drop Down
Senior Member
Senior Member


Joined: 19 Jul 2014
Location: loughborough uk
Status: Offline
Points: 3809
Post Options Post Options   Thanks (0) Thanks(0)   Quote johnno Quote  Post ReplyReply Direct Link To This Post Posted: 14 Nov 2018 at 21:04
Originally posted by Mike H Mike H wrote:

Is ECU actually getting any electric supply? E.g. dodgy connector(s) ...



this is also a very good point , I even added extra earth wire
1100 sport corsa rider
Back to Top
johnno View Drop Down
Senior Member
Senior Member


Joined: 19 Jul 2014
Location: loughborough uk
Status: Offline
Points: 3809
Post Options Post Options   Thanks (0) Thanks(0)   Quote johnno Quote  Post ReplyReply Direct Link To This Post Posted: 14 Nov 2018 at 21:11
Have you changed the chip in Ecu , it very easy to get a pin missed aligned
1100 sport corsa rider
Back to Top
Guztave View Drop Down
Senior Member
Senior Member


Joined: 30 Nov 2014
Location: Exeter
Status: Offline
Points: 308
Post Options Post Options   Thanks (0) Thanks(0)   Quote Guztave Quote  Post ReplyReply Direct Link To This Post Posted: 15 Nov 2018 at 20:39
We are trying all of the latest suggestions this weekend, will update you on how we get on
Back to Top
Guztave View Drop Down
Senior Member
Senior Member


Joined: 30 Nov 2014
Location: Exeter
Status: Offline
Points: 308
Post Options Post Options   Thanks (0) Thanks(0)   Quote Guztave Quote  Post ReplyReply Direct Link To This Post Posted: 22 Nov 2018 at 08:48
We have tested the original relays and all seem to operate as hey should but will replace them with the new ones from PYRODAN.

Have now tested the live and earth feeds to the ECU and we get a switched live from the brown/white wire on terminal 26 and earth feeds to black wires to terminals 17 and 34.

We also have tested the signal from the engine phase sensor to the ECU and this appears normal.

At the moment our suspicions are with the ECU but ideally would like to plug it in to another 1100 Sport to see if it is in fact at fault. Or can the ECU sent somewhere to be tested off the bike?
Back to Top
johnno View Drop Down
Senior Member
Senior Member


Joined: 19 Jul 2014
Location: loughborough uk
Status: Offline
Points: 3809
Post Options Post Options   Thanks (0) Thanks(0)   Quote johnno Quote  Post ReplyReply Direct Link To This Post Posted: 22 Nov 2018 at 13:15
i was lucky enough to get Muzzimoto to lend me another ecu for testing ,you really could do with someone close by who could let you try there ecu .
1100 sport corsa rider
Back to Top
johnno View Drop Down
Senior Member
Senior Member


Joined: 19 Jul 2014
Location: loughborough uk
Status: Offline
Points: 3809
Post Options Post Options   Thanks (0) Thanks(0)   Quote johnno Quote  Post ReplyReply Direct Link To This Post Posted: 22 Nov 2018 at 13:19
[QUOTE=johnno]i was lucky enough to get Muzzimoto to lend me another ecu for testing ,you really could do with someone close by who could let you try theres or they try yours . If you want to post to me i dont mind connecting it to my bike . 
1100 sport corsa rider
Back to Top
Guztave View Drop Down
Senior Member
Senior Member


Joined: 30 Nov 2014
Location: Exeter
Status: Offline
Points: 308
Post Options Post Options   Thanks (0) Thanks(0)   Quote Guztave Quote  Post ReplyReply Direct Link To This Post Posted: 22 Nov 2018 at 17:00
Hi Johnno,
You are an absolute gentlemen, this is most appreciated. PM me your address and I will post it to you next week.
Thanks for your help.
Back to Top
Brian UK View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 13 May 2014
Location: Surrey
Status: Offline
Points: 11007
Post Options Post Options   Thanks (0) Thanks(0)   Quote Brian UK Quote  Post ReplyReply Direct Link To This Post Posted: 22 Nov 2018 at 17:51
If you do find you have a problem with the ECU, it might be worth looking here.
Brian.

Better 5 minutes late in this world than years early in the next.
Back to Top
Guztave View Drop Down
Senior Member
Senior Member


Joined: 30 Nov 2014
Location: Exeter
Status: Offline
Points: 308
Post Options Post Options   Thanks (0) Thanks(0)   Quote Guztave Quote  Post ReplyReply Direct Link To This Post Posted: 22 Nov 2018 at 18:06
Thanks Brian, I will email them once Johnno has checked mine out ... fingers crossed!
Back to Top
johnno View Drop Down
Senior Member
Senior Member


Joined: 19 Jul 2014
Location: loughborough uk
Status: Offline
Points: 3809
Post Options Post Options   Thanks (0) Thanks(0)   Quote johnno Quote  Post ReplyReply Direct Link To This Post Posted: 22 Nov 2018 at 18:30
Hi sent pm and mobile number . This is how I do ECU  first  remove fuses  then disconnect battery leave 2 mins then disconnect ECU then I will connect your ECU then reconnect battery then add fuseu
1100 sport corsa rider
Back to Top
 Post Reply Post Reply Page  <1234>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.00
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.