Print Page | Close Window

1998 Sporti Not Communicating with Diagnostic PC

Printed From: guzziriders.org - moto guzzi forum
Category: Technical
Forum Name: Spine Frame
Forum Description: V11 etc.
URL: http://www.guzziriders.org/forum_posts.asp?TID=9431
Printed Date: 18 Sep 2019 at 13:06
Software Version: Web Wiz Forums 12.02 - http://www.webwizforums.com


Topic: 1998 Sporti Not Communicating with Diagnostic PC
Posted By: Guztave
Subject: 1998 Sporti Not Communicating with Diagnostic PC
Date Posted: 12 Nov 2018 at 13:51
My 1998 Sporti is currently in a local workshop, the engineer has connected it to the diagnostic PC (TEXA TXB for bike with the annual software update package which is fully up to date.) and it is not recognising the bike / ECU.

We connected the system to another Moto Guzzi in the workshop and had no problems,. Can anybody out there suggest what they think could be the problem?

Thanks  



Replies:
Posted By: Brian UK
Date Posted: 12 Nov 2018 at 16:01
Which other Guzzi did they try? Could be an age thing.


-------------
Brian.

Better 5 minutes late in this world than years early in the next.


Posted By: Guztave
Date Posted: 12 Nov 2018 at 16:05
It was a V9 Bobber, so you could be on to something there


Posted By: Brian UK
Date Posted: 12 Nov 2018 at 16:58
I suspect that will be the case.


-------------
Brian.

Better 5 minutes late in this world than years early in the next.


Posted By: red leader one
Date Posted: 12 Nov 2018 at 17:07
Ageism that is.


Posted By: Guztave
Date Posted: 12 Nov 2018 at 17:19
True, but looking that way. Will check and confirm asap


Posted By: johnno
Date Posted: 12 Nov 2018 at 19:58
My Corsa as never had a fault lol , interested in outcomeThumbs Up

-------------
1100 sport corsa , Yam R1, guzzi 650tt rider


Posted By: johnno
Date Posted: 12 Nov 2018 at 20:00
Only old skool ways work , please prove me wrongThumbs Up

-------------
1100 sport corsa , Yam R1, guzzi 650tt rider


Posted By: Brian UK
Date Posted: 12 Nov 2018 at 20:16
I might be wrong, but it's possible Guzzidiag might help.


-------------
Brian.

Better 5 minutes late in this world than years early in the next.


Posted By: Guztave
Date Posted: 12 Nov 2018 at 20:52
Excuse my ignorance, what id GuzziDiag?


Posted By: Brian UK
Date Posted: 12 Nov 2018 at 21:08
https://www.von-der-salierburg.de/download/GuzziDiag/" rel="nofollow - https://www.von-der-salierburg.de/download/GuzziDiag/

Computer software to check ECUs.

It does cover many different ECUs, but can't say if it does yours.


-------------
Brian.

Better 5 minutes late in this world than years early in the next.


Posted By: Brian UK
Date Posted: 12 Nov 2018 at 21:23
And a guide.
https://www.v11lemans.com/forums/index.php?showtopic=19641" rel="nofollow - https://www.v11lemans.com/forums/index.php?showtopic=19641


-------------
Brian.

Better 5 minutes late in this world than years early in the next.


Posted By: johnno
Date Posted: 12 Nov 2018 at 21:52
When my bike was plugged in it never shown any problems up , hope you have better luck 

-------------
1100 sport corsa , Yam R1, guzzi 650tt rider


Posted By: Guztave
Date Posted: 14 Nov 2018 at 11:57
Apparently no problems scanning the older Moto Guzzi bikes - it just seems to have an issue with my bike.

Yesterday,  we tried a noid light on the right injector plug - but no signal is getting there.

Also tried a replacement engine phase sensor which made no difference so would assume the original one fitted is OK.

The fact that both of these signals are absent might help narrow down where the fault might be?

Anybody with any thoughts on this?

Thanks


Posted By: johnno
Date Posted: 14 Nov 2018 at 12:59
is this still the fuel pump continually  running problem ?



-------------
1100 sport corsa , Yam R1, guzzi 650tt rider


Posted By: Guztave
Date Posted: 14 Nov 2018 at 15:05
Hi Johnno,

Yes, fuel pump continually running ...


Posted By: johnno
Date Posted: 14 Nov 2018 at 19:15
Have you checked relays and wiring . I took rear body work off so you can get to the wiring that goes to relays . 

-------------
1100 sport corsa , Yam R1, guzzi 650tt rider


Posted By: Guztave
Date Posted: 14 Nov 2018 at 19:29
Yes, relays are good but order new ones from PYRO DAN to be sure and removed all body work.

Thanks for your help.


Posted By: Mike H
Date Posted: 14 Nov 2018 at 21:00
Is ECU actually getting any electric supply? E.g. dodgy connector(s) ...





-------------
"Chicken nuggets don't dance on a Tuesday."


Posted By: johnno
Date Posted: 14 Nov 2018 at 21:03
When you have fuel pump running have you wiggle the relays ? My bike nearly drove me mad with problems . 

-------------
1100 sport corsa , Yam R1, guzzi 650tt rider


Posted By: johnno
Date Posted: 14 Nov 2018 at 21:04
Originally posted by Mike H Mike H wrote:

Is ECU actually getting any electric supply? E.g. dodgy connector(s) ...



this is also a very good point , I even added extra earth wire

-------------
1100 sport corsa , Yam R1, guzzi 650tt rider


Posted By: johnno
Date Posted: 14 Nov 2018 at 21:11
Have you changed the chip in Ecu , it very easy to get a pin missed aligned

-------------
1100 sport corsa , Yam R1, guzzi 650tt rider


Posted By: Guztave
Date Posted: 15 Nov 2018 at 20:39
We are trying all of the latest suggestions this weekend, will update you on how we get on


Posted By: Guztave
Date Posted: 22 Nov 2018 at 08:48
We have tested the original relays and all seem to operate as hey should but will replace them with the new ones from PYRODAN.

Have now tested the live and earth feeds to the ECU and we get a switched live from the brown/white wire on terminal 26 and earth feeds to black wires to terminals 17 and 34.

We also have tested the signal from the engine phase sensor to the ECU and this appears normal.

At the moment our suspicions are with the ECU but ideally would like to plug it in to another 1100 Sport to see if it is in fact at fault. Or can the ECU sent somewhere to be tested off the bike?


Posted By: johnno
Date Posted: 22 Nov 2018 at 13:15
i was lucky enough to get Muzzimoto to lend me another ecu for testing ,you really could do with someone close by who could let you try there ecu .

-------------
1100 sport corsa , Yam R1, guzzi 650tt rider


Posted By: johnno
Date Posted: 22 Nov 2018 at 13:19
[QUOTE=johnno]i was lucky enough to get Muzzimoto to lend me another ecu for testing ,you really could do with someone close by who could let you try theres or they try yours . If you want to post to me i dont mind connecting it to my bike . 

-------------
1100 sport corsa , Yam R1, guzzi 650tt rider


Posted By: Guztave
Date Posted: 22 Nov 2018 at 17:00
Hi Johnno,
You are an absolute gentlemen, this is most appreciated. PM me your address and I will post it to you next week.
Thanks for your help.


Posted By: Brian UK
Date Posted: 22 Nov 2018 at 17:51
If you do find you have a problem with the ECU, it might be worth looking here.
http://www.myecu.biz/MyECU/index.htm" rel="nofollow - http://www.myecu.biz/MyECU/index.htm


-------------
Brian.

Better 5 minutes late in this world than years early in the next.


Posted By: Guztave
Date Posted: 22 Nov 2018 at 18:06
Thanks Brian, I will email them once Johnno has checked mine out ... fingers crossed!


Posted By: johnno
Date Posted: 22 Nov 2018 at 18:30
Hi sent pm and mobile number . This is how I do ECU  first  remove fuses  then disconnect battery leave 2 mins then disconnect ECU then I will connect your ECU then reconnect battery then add fuseu

-------------
1100 sport corsa , Yam R1, guzzi 650tt rider


Posted By: Guztave
Date Posted: 23 Nov 2018 at 12:39
Hi Johnno,

Just to be clear, your suggestion : "This is how I do ECU  first  remove fuses  then disconnect battery leave 2 mins then disconnect ECU then I will connect your ECU then reconnect battery then add fuse"

Is this an additional test, or how best to unplug the ECU for sending to you?

Thanks for your help.


Posted By: Brian UK
Date Posted: 23 Nov 2018 at 12:49
I think it's the safest way to unplug yours.



-------------
Brian.

Better 5 minutes late in this world than years early in the next.


Posted By: Guztave
Date Posted: 23 Nov 2018 at 12:51
OK, Thanks Brian


Posted By: johnno
Date Posted: 23 Nov 2018 at 12:53
Hi i just wanted you to know how i disconnect and connect up an ECU ,we dont want any electrical flashing so if your happy with my process then im happy to check your ECU on my bike . If anyone knows a better way please feel free to shout up .Smile I really struggle to explain with the written word sorry 

-------------
1100 sport corsa , Yam R1, guzzi 650tt rider


Posted By: Guztave
Date Posted: 23 Nov 2018 at 13:28
Hi Johnno,
No problem, I am happy to send you my ECU - you are well ahead of my knowledge base.
Thanks


Posted By: Guztave
Date Posted: 24 Nov 2018 at 11:13
I thought I would share this advice from Towza :

I have been looking at the wiring for the Sport. The live feed to terminal 26 is a signal feed to the ECU to indicate that the kill switch is in the “ON” position, it also feeds the  coil of the Power Relay which is then controlled by the ECU at terminal 23. This is not the live feed for the ECU. The ECU power comes via the ECU relay which feeds the main power to terminal 35 and the check lamp. If you have no power you will have no diagnostics, I would check the power supply to terminal 35 which I believe is the brown wire.

Thoughts anyone?

Thanks


Posted By: johnno
Date Posted: 26 Nov 2018 at 19:47
Have you fitted new relays yet ? Have you moved chip ? Have you pulled a relay when fuel pump keeps running ? I love 1100 sport but lol

-------------
1100 sport corsa , Yam R1, guzzi 650tt rider


Posted By: Guztave
Date Posted: 26 Nov 2018 at 21:11
Yes Johnno,
Going over to see the bike Wednesday, going to try Towza’s suggestions before removing the ECU and posting to you
Thanks


Posted By: johnno
Date Posted: 27 Nov 2018 at 07:10
That now sounds like a planThumbs Up

-------------
1100 sport corsa , Yam R1, guzzi 650tt rider


Posted By: theoneandonly
Date Posted: 27 Nov 2018 at 20:52
Originally posted by Guztave Guztave wrote:

Hi Johnno,

Yes, fuel pump continually running ...

fucked ecu .i have £1 says i'm right 


-------------
https://www.facebook.com/BaldricksWorkshop
http://baldricksworkshop.co.uk/

motorcycle slut, if it has wheels and an engine , i will ride it .


Posted By: johnno
Date Posted: 27 Nov 2018 at 21:43
Originally posted by theoneandonly theoneandonly wrote:

Originally posted by Guztave Guztave wrote:

Hi Johnno,

Yes, fuel pump continually running ...
fucked ecu .i have £1 says i'm right 
a £1 says you're wrong Thumbs Up

-------------
1100 sport corsa , Yam R1, guzzi 650tt rider


Posted By: red leader one
Date Posted: 27 Nov 2018 at 23:32
A shilling even money.


Posted By: johnno
Date Posted: 30 Nov 2018 at 18:00
ECU as arrived because it's the main man saying the ECU is f______ I'm starting to have a growing doubt about being right lol

-------------
1100 sport corsa , Yam R1, guzzi 650tt rider


Posted By: theoneandonly
Date Posted: 30 Nov 2018 at 18:18
Originally posted by johnno johnno wrote:

ECU as arrived because it's the main man saying the ECU is f______ I'm starting to have a growing doubt about being right lol

 just put your hand in your pocket , it only hurts for a moment ! 


-------------
https://www.facebook.com/BaldricksWorkshop
http://baldricksworkshop.co.uk/

motorcycle slut, if it has wheels and an engine , i will ride it .


Posted By: johnno
Date Posted: 30 Nov 2018 at 18:35
I will personally hand me quid over , but I do hope I'm right then Aldo will have some money still in the bankThumbs Up

-------------
1100 sport corsa , Yam R1, guzzi 650tt rider


Posted By: johnno
Date Posted: 02 Dec 2018 at 12:12
The undisputed champion is once again THEONEANDONLY bollocks lol. Sorry to say after riding me Corsa for 10 miles which ran perfect I changed ECU over and fuel pump kept running.

-------------
1100 sport corsa , Yam R1, guzzi 650tt rider


Posted By: Brian UK
Date Posted: 02 Dec 2018 at 13:41
So what next?


-------------
Brian.

Better 5 minutes late in this world than years early in the next.


Posted By: Guztave
Date Posted: 02 Dec 2018 at 14:50
A new ECU from Cliff Jefferies and complete rewire by Towzatronics


Posted By: Guztave
Date Posted: 15 Sep 2019 at 13:21
New ECU from Cliff Jefferies fitted by Towzatronics, better than the original I think.

MDL here we come!



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.02 - http://www.webwizforums.com
Copyright ©2001-2019 Web Wiz Ltd. - https://www.webwiz.net