guzziriders.org - moto guzzi forum Homepage
Forum Home Forum Home > Technical > Oil
  New Posts New Posts RSS Feed - V7:Changed Gear box & fnal drive oil, oil light on
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

V7:Changed Gear box & fnal drive oil, oil light on

 Post Reply Post Reply
Author
Message
ryandelga View Drop Down
Guzzino
Guzzino
Avatar

Joined: 12 Jul 2021
Location: California
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote ryandelga Quote  Post ReplyReply Direct Link To This Post Topic: V7:Changed Gear box & fnal drive oil, oil light on
    Posted: 12 Jul 2021 at 02:52
Hey Y'all,

I have been having problems with my gears getting crunchy and hard to shift when the bike warms up so I decided to change the Gear Box Oil and Final Drive oil. After I changed the oil the oil pressure sensor light is now on. Where did I go wrong?

I put 1 Liter of 80w 90 in the Gear Box the bike was upright (not on kickstand) and some oil topped off and dribbled out the Level plug. I have released maybe about 200 ML or more after i noticed the light was on and it hasn't helped. I figure this is the issue but I am pretty green when it comes to motorcycle maintenance.

The Final Drive I put about 160 - 170ML of 85w 140 in it. 

I skipped the engine oil and filter for this maintenance because I changed that maybe less than 500 miles ago. Maybe thats the issue?

I also didnt use a Torque Wrench so maybe thats where I screwed up. 

PLEASE HELP!!!! I have recently moved to the sierras and there are no Guzzi Mechanics nearby, I am on my own. You're my only hope...
Get Sick.
Back to Top
Richard Hyatt View Drop Down
Senior Member
Senior Member


Joined: 14 Oct 2019
Location: Dorset
Status: Offline
Points: 1080
Post Options Post Options   Thanks (0) Thanks(0)   Quote Richard Hyatt Quote  Post ReplyReply Direct Link To This Post Posted: 12 Jul 2021 at 06:25
I cannot see any corellation between doing what you've done and the engine oil pressure light coming on.
The engine oil light shows if there is/is not any pressure in the oil pump circuit and is not affected by the gearbox oil change.
If you had disturbed the connection to the oil pressure switch and somehow knocked the wire off the top of the switch, the oil light wouldn't come on.
At this moment , I'm. Lost, but others will contribute.
What year is your bike and mileage, and had anything else been going on or developing with it?
Back to Top
Brian UK View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 13 May 2014
Location: Surrey
Status: Offline
Points: 16725
Post Options Post Options   Thanks (0) Thanks(0)   Quote Brian UK Quote  Post ReplyReply Direct Link To This Post Posted: 12 Jul 2021 at 07:48
Originally posted by ryandelga ryandelga wrote:

I have been having problems with my gears getting crunchy and hard to shift when the bike warms up so I decided to change the Gear Box Oil and Final Drive oil. After I changed the oil the oil pressure sensor light is now on. Where did I go wrong?


If you changed the oil pressure sensor then that will be the problem, either you haven't connected it correctly or the switch is not working. Possibly the wire has chafed and is shorting to the frame somewhere. Though I don't know why you would have touched the oil pressure sensor when changint the oils in the transmission end.

But crunchy gears are almost certainly due to clutch adjustment, so it's unlikely that changing the oil will make much difference.


Edited by Brian UK - 12 Jul 2021 at 07:51
Brian.

Better 5 minutes late in this world than years early in the next.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.03
Copyright ©2001-2019 Web Wiz Ltd.

This page was generated in 0.047 seconds.